use strict;
my $str = 'new stackoverflow 244code 7490script design';
my $regex = qr~(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d)~ip;
my $subst = ' ';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";