re = /(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d)/i
str = 'new stackoverflow 244code 7490script design'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result