#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(<a href=\\"http:\/\/example\.com\/path-pattern-to-match\/)([^>]*)\\">"
Local $sString = "<a href=\"http://example.com/path-pattern-to-match/someArticle\"> <a href=\"http://example.com/path-pattern-to-match/subPath/onemoreSubpath/arbitrary-number-of-subpaths/someArticle\">" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)