const regex = /(<a href=\\"http:\/\/example\.com\/path-pattern-to-match\/)([^>]*)\\">/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a href=\\\\"http:\\\/\\\/example\\.com\\\/path-pattern-to-match\\\/)([^>]*)\\\\">', 'gi')
const str = `<a href=\\"http://example.com/path-pattern-to-match/someArticle\\"> <a href=\\"http://example.com/path-pattern-to-match/subPath/onemoreSubpath/arbitrary-number-of-subpaths/someArticle\\">
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);