using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a href=\\""http:\/\/example\.com\/path-pattern-to-match\/)([^>]*)\\"">";
string substitution = @"";
string input = @"<a href=\""http://example.com/path-pattern-to-match/someArticle\""> <a href=\""http://example.com/path-pattern-to-match/subPath/onemoreSubpath/arbitrary-number-of-subpaths/someArticle\"">
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}