// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)(<a href=\\"http:\/\/example\.com\/path-pattern-to-match\/)([^>]*)\\">"#).unwrap();
let string = "<a href=\\\"http://example.com/path-pattern-to-match/someArticle\\\"> <a href=\\\"http://example.com/path-pattern-to-match/subPath/onemoreSubpath/arbitrary-number-of-subpaths/someArticle\\\">
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}