$re = '/(<a href=\\\\"http:\/\/example\.com\/path-pattern-to-match\/)([^>]*)\\\\">/i';
$str = '<a href=\\"http://example.com/path-pattern-to-match/someArticle\\"> <a href=\\"http://example.com/path-pattern-to-match/subPath/onemoreSubpath/arbitrary-number-of-subpaths/someArticle\\">
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;