import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^interface\\b.*(?:\\r?\\n(?!=).*)*";
final String string = "======\n\n"
+ "interface And\n\n"
+ "public void and(int, int);\n\n"
+ "public void nand(int, int);\n\n"
+ "======\n\n"
+ "interface Or\n\n"
+ "public void or(int, int); public void nor(int, int);\n\n"
+ "======\n\n"
+ "interface Xor\n\n"
+ "public void xor(int, int); public void xnor(int, int);\n\n"
+ "======\n\n"
+ "interface Not\n\n"
+ "public void not(int);\n\n"
+ "======\n\n"
+ "class BitWise extends And, Or, Xor, Not\n\n"
+ "// Implementation of the Interfaces goes here\n\n"
+ "======\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}