import re
regex = re.compile(r"^interface\b.*(?:\r?\n(?!=).*)*", flags=re.MULTILINE)
test_str = ("======\n\n"
"interface And\n\n"
"public void and(int, int);\n\n"
"public void nand(int, int);\n\n"
"======\n\n"
"interface Or\n\n"
"public void or(int, int); public void nor(int, int);\n\n"
"======\n\n"
"interface Xor\n\n"
"public void xor(int, int); public void xnor(int, int);\n\n"
"======\n\n"
"interface Not\n\n"
"public void not(int);\n\n"
"======\n\n"
"class BitWise extends And, Or, Xor, Not\n\n"
"// Implementation of the Interfaces goes here\n\n"
"======\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")