import Foundation
let pattern = #"^interface\b.*(?:\r?\n(?!=).*)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
======
interface And
public void and(int, int);
public void nand(int, int);
======
interface Or
public void or(int, int); public void nor(int, int);
======
interface Xor
public void xor(int, int); public void xnor(int, int);
======
interface Not
public void not(int);
======
class BitWise extends And, Or, Xor, Not
// Implementation of the Interfaces goes here
======
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)