package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d{5,}\b`)
var str = `We’re in 2014, but this number is not 5-digits long. However, 20145 is matched, like 345421234 but not a425234 nor 123455x.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}