re = /\b\d{5,}\b/
str = 'We’re in 2014, but this number is not 5-digits long. However, 20145 is matched, like 345421234 but not a425234 nor 123455x.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end