// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b\d{5,}\b").unwrap();
let string = "We’re in 2014, but this number is not 5-digits long. However, 20145 is matched, like 345421234 but not a425234 nor 123455x.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}