import re
regex = re.compile(r"\b\d{5,}\b")
test_str = "We’re in 2014, but this number is not 5-digits long. However, 20145 is matched, like 345421234 but not a425234 nor 123455x."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")