using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":(.*?)\(?";
string input = @"virtual void NameSpace1::NameSpace2::ClassName1::function_name1(int arg1) const
void function_name2
void NameSpace2::NameSpace4::ClassName2::function_name3
function_name4";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}