import re
regex = re.compile(r":(.*?)\(?")
test_str = ("virtual void NameSpace1::NameSpace2::ClassName1::function_name1(int arg1) const\n"
"void function_name2\n"
"void NameSpace2::NameSpace4::ClassName2::function_name3\n"
"function_name4")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")