import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":(.*?)\\(?";
final String string = "virtual void NameSpace1::NameSpace2::ClassName1::function_name1(int arg1) const\n"
+ "void function_name2\n"
+ "void NameSpace2::NameSpace4::ClassName2::function_name3\n"
+ "function_name4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}