import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# header 1(?:[^#]*|(?!# header 2)#)*";
final String string = "# header 1\n"
+ "Lorem ipsum\n\n"
+ "# random header\n"
+ "dolor si\n\n"
+ "# header 2\n"
+ "loram ipsum";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}