re = /# header 1(?:[^#]*|(?!# header 2)#)*/i
str = '# header 1
Lorem ipsum
# random header
dolor si
# header 2
loram ipsum'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end