$re = '/# header 1(?:[^#]*|(?!# header 2)#)*/i';
$str = '# header 1
Lorem ipsum
# random header
dolor si
# header 2
loram ipsum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);