package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[[^\][]*\]|\b(\d+)\b`)
var str = `1234 [ blabla 101112 ] 67890 [113141516 ] bla171819 212123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}