$re = '/\[[^\][]*\]|\b(\d+)\b/i';
$str = '1234 [ blabla 101112 ] 67890 [113141516 ] bla171819 212123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);