// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\[[^\][]*\]|\b(\d+)\b").unwrap();
let string = "1234 [ blabla 101112 ] 67890 [113141516 ] bla171819 212123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}