const regex = /\[[^\][]*\]|\b(\d+)\b/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[[^\\][]*\\]|\\b(\\d+)\\b', 'ig')
const str = `1234 [ blabla 101112 ] 67890 [113141516 ] bla171819 212123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}