re = /\[[^\][]*\]|\b(\d+)\b/i
str = '1234 [ blabla 101112 ] 67890 [113141516 ] bla171819 212123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end