#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\s(?!((\s\/\s)|(,\s)))"
Local $sString = "Heparin Sodium,Porcine" & @CRLF & _
"Heparin Sodium, Porcine" & @CRLF & _
"Very / Very / Long-Word" & @CRLF & _
"a a" & @CRLF & _
"a a" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")