$re = '/\s(?!((\s\/\s)|(,\s)))/u';
$str = 'Heparin Sodium,Porcine
Heparin Sodium, Porcine
Very / Very / Long-Word
a a
a a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);