re = /\s(?!((\s\/\s)|(,\s)))/
str = 'Heparin Sodium,Porcine
Heparin Sodium, Porcine
Very / Very / Long-Word
a a
a a
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end