using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?!((\s\/\s)|(,\s)))";
string input = @"Heparin Sodium,Porcine
Heparin Sodium, Porcine
Very / Very / Long-Word
a a
a a
";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}