import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(?!((\\s\\/\\s)|(,\\s)))";
final String string = "Heparin Sodium,Porcine\n"
+ "Heparin Sodium, Porcine\n"
+ "Very / Very / Long-Word\n"
+ "a a\n"
+ "a a\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}