using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""[^""\\]*(?:\\.[^""\\]*)*""|'[^'\\]*(?:\\.[^'\\]*)*')|/\*[^*]*\*+(?:[^/*][^*]*\*+)*/|//.*[\r\n]*";
string substitution = @"\1";
string input = @"random text
/* removable comment */
""but /* never remove this */ one""
'but /* never remove this */ one either'
// Text here
more random *text*
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}