$re = '/("[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\')|/\*[^*]*\*+(?:[^/*][^*]*\*+)*/|//.*[\r\n]*/';
$str = 'random text
/* removable comment */
"but /* never remove this */ one"
\'but /* never remove this */ one either\'
// Text here
more random *text*
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;