const regex = new RegExp('\\{\\{.*?\\}\\}|\\{%.*?%}', 'gm')
const str = `{% if statement is true %}
The true thing
{% else %}
the false thing
{% endif %}
{% if {{custom_attribute.\${total_spend}}} >0 %}
Thanks for purchasing! Here's another 10% off!
{% else %}
Buy now! Would 5% off convince you?
{% endif %}
----
Something something {{userAttribute}} something else.
Hi {{ \${first_name} | default: 'Valued User' }}, thanks for using the App!
-- note that the example had an extra right bracket:
{{\${first_name} | capitalize | strip | default: 'friend'}}}
{{\${first_name} | capitalize | strip | default: 'friend'}}
-- Suggested more localization friendly method instead of "default": --
Hello {% if \${first_name} == "" %}friend{% else %}{{\${first_name}| capitalize | strip}}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}