import Foundation
let pattern = #"\{\{.*?\}\}|\{%.*?%}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{% if statement is true %}
The true thing
{% else %}
the false thing
{% endif %}
{% if {{custom_attribute.${total_spend}}} >0 %}
Thanks for purchasing! Here's another 10% off!
{% else %}
Buy now! Would 5% off convince you?
{% endif %}
----
Something something {{userAttribute}} something else.
Hi {{ ${first_name} | default: 'Valued User' }}, thanks for using the App!
-- note that the example had an extra right bracket:
{{${first_name} | capitalize | strip | default: 'friend'}}}
{{${first_name} | capitalize | strip | default: 'friend'}}
-- Suggested more localization friendly method instead of "default": --
Hello {% if ${first_name} == "" %}friend{% else %}{{${first_name}| capitalize | strip}}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)