re = /\{\{.*?\}\}|\{%.*?%}/m
str = '{% if statement is true %}
The true thing
{% else %}
the false thing
{% endif %}
{% if {{custom_attribute.${total_spend}}} >0 %}
Thanks for purchasing! Here\'s another 10% off!
{% else %}
Buy now! Would 5% off convince you?
{% endif %}
----
Something something {{userAttribute}} something else.
Hi {{ ${first_name} | default: \'Valued User\' }}, thanks for using the App!
-- note that the example had an extra right bracket:
{{${first_name} | capitalize | strip | default: \'friend\'}}}
{{${first_name} | capitalize | strip | default: \'friend\'}}
-- Suggested more localization friendly method instead of "default": --
Hello {% if ${first_name} == "" %}friend{% else %}{{${first_name}| capitalize | strip}}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end