# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{\{.*?\}\}|\{%.*?%}"
test_str = ("{% if statement is true %} \n"
"The true thing\n"
"{% else %}\n"
"the false thing\n"
"{% endif %} \n\n\n"
"{% if {{custom_attribute.${total_spend}}} >0 %}\n"
"Thanks for purchasing! Here's another 10% off!\n"
"{% else %}\n"
"Buy now! Would 5% off convince you?\n"
"{% endif %}\n"
"----\n\n"
"Something something {{userAttribute}} something else.\n\n\n"
"Hi {{ ${first_name} | default: 'Valued User' }}, thanks for using the App!\n\n"
"-- note that the example had an extra right bracket:\n"
"{{${first_name} | capitalize | strip | default: 'friend'}}}\n\n"
"{{${first_name} | capitalize | strip | default: 'friend'}}\n\n\n"
"-- Suggested more localization friendly method instead of \"default\": --\n\n"
"Hello {% if ${first_name} == \"\" %}friend{% else %}{{${first_name}| capitalize | strip}}\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.