# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-Z0-9]+):"(.*?)"(?=,[a-zA-Z0-9]+:"|$)//gm;t' <<< "joe:\"Look over there\, :it's a shark!\",sam:\"I like fish\\\""