use strict;
my $str = 'joe:"Look over there\\, :it\'s a shark!",sam:"I like fish\\\\"';
my $regex = qr/([a-zA-Z0-9]+):"(.*?)"(?=,[a-zA-Z0-9]+:"|$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";