$re = '/([a-zA-Z0-9]+):"(.*?)"(?=,[a-zA-Z0-9]+:"|$)/m';
$str = 'joe:"Look over there\\, :it\'s a shark!",sam:"I like fish\\\\"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;