import re
regex = re.compile(r"([a-zA-Z0-9]+):\"(.*?)\"(?=,[a-zA-Z0-9]+:\"|$)", flags=re.MULTILINE)
test_str = "joe:\"Look over there\\, :it's a shark!\",sam:\"I like fish\\\\\""
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)