const regex = /([a-zA-Z0-9]+):"(.*?)"(?=,[a-zA-Z0-9]+:"|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9]+):"(.*?)"(?=,[a-zA-Z0-9]+:"|$)', 'gm')
const str = `joe:"Look over there\\, :it's a shark!",sam:"I like fish\\\\"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);