# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^(.*?) \[?|(?<!^)\G){?([\w]*)}?//gm;t' <<< "text {text1}
anotherText [{text2} {text3}]"