using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^(.*?) \[?|(?<!^)\G){?([\w]*)}?";
string substitution = @"";
string input = @"text {text1}
anotherText [{text2} {text3}]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}