$re = '/(?:^(.*?) \[?|(?<!^)\G){?([\w]*)}?/m';
$str = 'text {text1}
anotherText [{text2} {text3}]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;