const regex = /(?:^(.*?) \[?|(?<!^)\G){?([\w]*)}?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^(.*?) \\[?|(?<!^)\\G){?([\\w]*)}?', 'gm')
const str = `text {text1}
anotherText [{text2} {text3}]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);