import Foundation
let pattern = #"(?:^(.*?) \[?|(?<!^)\G){?([\w]*)}?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
text {text1}
anotherText [{text2} {text3}]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)