#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{8}$)([1-9]\d*|0)\.\d{1,2}$"
Local $sString = "12345.12" & @CRLF & _
"123456.1" & @CRLF & _
"12345678" & @CRLF & _
"1234567.8" & @CRLF & _
"12345.678" & @CRLF & _
"123.0" & @CRLF & _
"12345678" & @CRLF & _
"123.12" & @CRLF & _
"1.2345678" & @CRLF & _
"12.345678" & @CRLF & _
"00010.12" & @CRLF & _
"0.12" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")