re = /^(?=.{8}$)([1-9]\d*|0)\.\d{1,2}$/m
str = '12345.12
123456.1
12345678
1234567.8
12345.678
123.0
12345678
123.12
1.2345678
12.345678
00010.12
0.12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end