import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{8}$)([1-9]\\d*|0)\\.\\d{1,2}$";
final String string = "12345.12\n"
+ "123456.1\n"
+ "12345678\n"
+ "1234567.8\n"
+ "12345.678\n"
+ "123.0\n"
+ "12345678\n"
+ "123.12\n"
+ "1.2345678\n"
+ "12.345678\n"
+ "00010.12\n"
+ "0.12\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}