using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{8}$)([1-9]\d*|0)\.\d{1,2}$";
string input = @"12345.12
123456.1
12345678
1234567.8
12345.678
123.0
12345678
123.12
1.2345678
12.345678
00010.12
0.12
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}